Peloton Forum banner
1 - 8 of 8 Posts

· Registered
149 Posts
Discussion Starter · #1 · (Edited)
Here's one for your ex-Peloton Field Tech people.

I have a problem with my Bike+ that I can't find any previous posts on.

Problem: The Bike+ powers on and appears to report resistance changing from 0 to 100 on the tablet but the resistance on the pedals/flywheel never changes. It remains easy and never changes.
  • The magnets along the flywheel NEVER move when turning the resistance knob.
  • Pedaling cadence changes on the tablet as you pedal faster and slower correctly. So, this works correctly.
  • Pushing down on the mechanical break does move and stop the flywheel (this is mechanical and not electronic). This works.
  • However, the initial Hardware Calibration does NOT go to 100% complete. Always stops around 17%. (see attached video)

Problem Diagnosis and observations:
  • Changing resistance on bike reports changing from 0 to 100 but never changes resistance on the flywheel. Magnets never move when viewing them.
  • Performing Hardware Calibration starts and ONLY goes up to about 17% and then reports “Your Calibration Process is Complete”. It NEVER goes up to 100 as it should.
  • There is NO noise from the sensor/resistance electronics when turning the knob. Only a very slight noise when powering on the bike.
  • There are NO errors reported anywhere on the display. The bike android display thinks it’s working perfectly.

Diagnostics steps I tried:
  • Pulled power from back of bike for 60 seconds and restarted.
  • Disconnected display and held power and volume up for 60 seconds
  • Cleared cache and other cleanup from settings
  • Factory Wipe/Reset from boot OS (Tap power and hold volume up) to reinitialize to factory default
  • I disassembled the sweat guard over the resistance mechanism. Removed all small white clips and re-inserted them into the sensor.
  • Removed and reseated USB-C cable below the resistance knob. Pulled USB-C from back of display and reseated.
I worked with the Peloton Whisperer on the Facebook page on this and we tried many of these steps multiple times (factory wipe, resistance etc) but had zero success. At this point he believe it’s a defective wheel sensor/resistance mechanism.

Has anyone seen this or know of a fix?

1 - 8 of 8 Posts