Peloton Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hello, I have not had any readings for this for months. Peloton initially said I was out of warranty and said I would need to buy a new cord; then decided to send one, that did not work, then they said I needed to buy a new sensor; then decided to send a new one, that also did not work, did a static reset and factory reset, still not working, not they say I need to buy an entirely new screen for $550. Has anyone else had this issue? I am so upset that we have lost months of use and that they now feel it's not their responsibility to fix and replace parts that are not even two years old. This is a home-use bike as well, not at a studio. Has anyone else had this issue? Has anyone had Peloton replace a screen? Thanks
 

·
Registered
Joined
·
14 Posts
If you have replaced the cable and sensor (which rarely fail) and confirmed ALL the cables are connected, then it's likely the port inside the tablet. It sounds like you made the unfortunate decision to NOT purchase the extended warranty which would cover the replacement. If you don't want to replace the tablet, you could try poking around inside the sensor cable port on the bike tablet and see if you can find the failure.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
If you have replaced the cable and sensor (which rarely fail) and confirmed ALL the cables are connected, then it's likely the port inside the tablet. It sounds like you made the unfortunate decision to NOT purchase the extended warranty which would cover the replacement. If you don't want to replace the tablet, you could try poking around inside the sensor cable port on the bike tablet and see if you can find the failure.
thanks, I don't think we were ever given a warranty option. I will try your idea out
 
1 - 4 of 4 Posts
Top