Peloton Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
36 Posts
Discussion Starter · #1 ·
Maybe I’m doing something wrong but I am having trouble latching the belt when I’m putting on each shoe. Maybe my shoes are faulty. It takes me quite a lot of time and effort and I think it should be easier. Any suggestions? Do I need to request replacements?
thank you
 

·
Registered
Joined
·
5 Posts
Are you holding up the catch on the clip , or the release button when you're trying to do this ? There should be no difficulty whatsoever to put the strap in, leave the buckle alone, simply enter the strap into the buckle and press it in gently. There is NO force required at all.
 

·
Registered
Joined
·
36 Posts
Discussion Starter · #5 ·
Are you holding up the catch on the clip , or the release button when you're trying to do this ? There should be no difficulty whatsoever to put the strap in, leave the buckle alone, simply enter the strap into the buckle and press it in gently. There is NO force required at all.
[/QUOT]
Are you holding up the catch on the clip , or the release button when you're trying to do this ? There should be no difficulty whatsoever to put the strap in, leave the buckle alone, simply enter the strap into the buckle and press it in gently. There is NO force required at all.
It doesn’t catch unless I force the strap about as far as it will go. I don’t hold up on the clip or the release button.
thanks for the response. I’ll keep trying and I’ll try to find the correct way to easily get the buckle secure. Is there a video ?
 

·
Registered
Joined
·
5 Posts
Unless there are no teeth on the strap , or the ratchet part of the buckle has broken off , I'm simply at a loss to understand what the problem is.
 

·
Registered
Joined
·
36 Posts
Discussion Starter · #7 ·
Unless there are no teeth on the strap , or the ratchet part of the buckle has broken off , I'm simply at a loss to understand what the problem is.
After a lot of effort, it catches . Thank you for your suggestions, I’ll work on my technique.
 

·
Registered
Joined
·
1 Posts
I got new shoes about a month ago and I have a high instep and I have a similar issue where when I enter the strap in to ratchet it does not work and I found that when strap goes over and in to ratchet the part where strap pulls over to other side of shoe catches and it’s not far enough in ratchet i put it down to my high instep and now I just pull strap over further to the ratchet and push it in to ratchet then use ratchet while pushing strap in and seems to work but I think it’s more my issue than a fault
 

·
Registered
Joined
·
36 Posts
Discussion Starter · #9 ·
I got new shoes about a month ago and I have a high instep and I have a similar issue where when I enter the strap in to ratchet it does not work and I found that when strap goes over and in to ratchet the part where strap pulls over to other side of shoe catches and it’s not far enough in ratchet i put it down to my high instep and now I just pull strap over further to the ratchet and push it in to ratchet then use ratchet while pushing strap in and seems to work but I think it’s more my issue than a fault
Thank you for explaining the problem, as I could not explain it . Thank you
 
1 - 9 of 9 Posts
Top