Peloton Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
My tread screen suddenly stopped working. It says "Android is starting optimizing storage” and then you see the P logo but then fails to a flashing white screen. We believe a glitch occurred during on of the pushed updates. We've tried to call Peloton Support twice but they've only suggested buying a new monitor at $600 which is frustrating because there has to be a software fix to this. I wish they'd provide the software update to reload to the operating system. We've tried unplugging, turning off on, etc. but cannot access the screen to push an update through that way (as it only flashes white). Any advice, please help! The tread after just a year is now unusable. Lesson learned: buy the extended warranty...which we are no longer allowed to purchase since our year since purchase has recently passed.
 

·
Registered
Joined
·
3 Posts
Having a similar issue now with our bike. Was your problem ever resolved or did u have to buy a new monitor???
I followed the advice above (unplugged at the back and rebooted) and it after a couple tries it miraculously worked. Haven’t had any issues since (I now leave my monitor sleeping though because I’ve read it can be caused by failed updates when your bike is powered off).
 

·
Registered
Joined
·
1 Posts
Thanks I’ll keep trying that and maybe a miracle will happen. We always leave ours in sleep mode but maybe there was a power surge.
Did you have any luck with repairing your screen? I did an update this morning and the flashing screen started right after. I’ve tried several online suggestions but have had no luck. Of course, customer service is closed now.
 
1 - 10 of 10 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top